Raphael +
  • Stay hungry, Stay foolish.
  • albus.zly@gmail.com
    albus12138

    Minecraft Mod 开发

    开发环境搭建

    1.7.10已经是一个很古老的版本了……很多文档都有或多或少的问题,记录下配置过程。一开始我是想用IDEA的,在多次尝试失败后还是用了eclipse。IDEA 失败的原因似乎是因为 1.7.10 forge 使用的 gradle 版本过低,无法识别出 openjdk_1.8 的版本号,因此导致 IDEA 的 gradle 面板无法使用,手动提升 gradle 版本是可行的,但 gradle 版本过高后会导致无法从 maven 仓库中找到 forge 插件,我也没有具体测试是否存在既兼容 openjdk_1.8 又能找到对应 forge 插件的版本。

    还有就是由于某些原因,建议全程使用 SSR 全局模式或 proxychains 等工具加速,避免网络问题出现错误。

    Blog

    Coding

    Bookmarks